upgrade

I’m about to upgrade my blog software from MT 2.6 to 3.1. If things go completely b0rked here that’s whats up.

MT’s upgrade documentation leaves a whole lot to be desired. No readme file, nothing called out as START HERE FIRST. There is an upgrade page in the manual (in the docs directory), but it is named differently from the other files so its hard to find (I missed it entirely and ended up googling for the same file).

It turns out the upgrade process is to copy the files from 3.1 into the old 2.6 directory. By hand. And make sure you don’t overwrite anything you might have changed. Uhh. Does that include templates? Uhhhh. Hard to say. The upgrade docs are not reassuring. They are positively terrifying, actually. NOTE NOTE NOTE do not… be sure… you will need to…. ack!

You know, an installer script would really come in handy right about now. Lots of programs have them these days. Lots of FREE programs have very good installers. For $70 I’d like a little hand-holding, please.

It also doesn’t help that in googling I found some vague warnings that in addition to upgrading my MT software I’m also going to have to hand-upgrade my MT templates to use the new features, but there are no docs about that. Uhhhh.

I have backed up my postings. I have a stiff drink poured. I have the fear.

Here we go.

Update: OK, that wasn’t bad at all. I see no b0rkage yet. Please let me know if you find some (see email links at left)